
Computer Programming in 
Python

Chapter 2

The Python Shell and IDLE



• The Python Language
– Python is a high-level, general-purpose language

– Created by Guido van Rossum and introduced in 1991

– Emphasizes code readability and is similar in many 
respects to pseudocode

– The name Python comes from the famous British comedy 
Monty Python’s Flying Circus
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• The Python Language
– An interpretive language

• Uses an interpreter to translate the code one line at a time 
and execute it

• Interpretive languages tend to be slower than direct native 
machine code, and can be reverse engineered more easily, 
so their use should be restricted to areas where this is not 
an issue
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• The Python Language
– Supports procedural programming and object oriented 

programming

• More on this later

– Simple yet strong language with many supporting 
libraries (code written by others that we can use) as well 
as a standard library containing extensive capability
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• The Python Language
– Open Source Software

• Software with source code that anyone can inspect, 
modify, and enhance

– Developed under an OSI-approved open source license

• Makes it free to use and distribute including for 
commercial use
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Available free to download and use from Python.org



• Getting and Installing Python
– The website URL and steps to obtain and install Python 

are provided in Appendix B

• Python should be installed before continuing in this 
chapter

– The installation for Python includes:

• The interpreter for executing Python code

• The IDLE Integrated Development Environment for 
developing programs

• Many libraries that provide functionality without having to 
write the code
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• Getting and Installing Python
– Once Python is installed, IDLE is launched using the 

idle.bat located in the Lib/idlelib directory
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• Getting and Installing Python
– A short-cut can be created at a higher level to eliminate 

drilling down into the sub-directory each time IDLE is 
launched
• Right mouse click in the directory location for the short-cut

• Select -> NEW -> Shortcut

• Click on the “Browse” button and browse to the idle.bat file

• Select idle.bat and click “Next”

• Name the shortcut and click “Finish”
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To see file extensions like “bat”, click the View tab on the window, and 
check the box for “File Name Extensions”



• Right mouse click in the directory location for the short-cut

• Select -> NEW -> Shortcut

• Click on the “Browse” button and browse to the idle.bat file

• Select idle.bat and click “Next”

• Name the shortcut and click “Finish”
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• The complete path to the idle.bat should be in the create 
shortcut location

• Click “Next”
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• Now give the shortcut a name – shown here as Launch Idle

• Then click “Finish”
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• The shortcut to the idle.bat file should be in your working 
directory (shown here as “Launch Idle”)

Chris Simber 2021 - All Rights Reserved 12

Chapter 2 Python



• The Python Shell
– When double-clicked or accessed from the short-cut, 

idle.bat will open the Python Shell shown below

– This is the Python interpreter in interactive mode

Chris Simber 2021 - All Rights Reserved 13

Chapter 2 Python



• The Python Shell
– Python statements can be run directly in the shell

– Typing a single line in the shell and pressing Enter will 
execute the line using the interpreter

– An easy way to demonstrate this is with a print 
statement
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• In the editor, after the “>>>” type:

print (“This is a course in Python”)

• Notice the text color coding (more on this later)
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• The Python Shell

– A line of code entered into the shell will execute when 

Enter is pressed

– The prompt waiting for input in the shell is ‘>>>’
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• The Python Shell

– The words in the statements are color coded to highlight that 
they are different items

– Also notice that the ‘>>>’ prompt appears again after the 
output waiting for an additional statement to execute
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• The Python Shell

– The line of code added here includes an equation

– When Enter is pressed, the text in quotes and the result 
of the equation are displayed in the output
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• The Python Shell

– The first print statement surrounds the text to output 
with single quotes

– The second print statement uses double quotes

– Python doesn’t care which is used, but it is important to 
be consistent
• More on this later
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• The Python Shell
– Works well for one line of code, snippets, or examples

– The goal is to write complete Python programs

– The shell simply uses the interpreter to execute the line 
that was typed when Enter is pressed

– Files will be used to write and execute more complex 
programs using the interpreter in script mode

• The interpreter will read the contents of a file to execute 
multiple lines of code (a program)

Chris Simber 2021 - All Rights Reserved 20

Chapter 2 Python



• The IDLE Development Environment
– IDLE stands for “Integrated Development and Learning 

Environment”

– Intended to be a simple Integrated Development 
Environment (IDE):

• It is cross-platform (runs on multiple operating systems 
and computers)

• It is suitable for starting out in Python especially in an 
educational setting

Chris Simber 2021 - All Rights Reserved 21

Chapter 2 Python



• The IDLE Development Environment
– Provides a multi-window text editor and Python shell 

with syntax highlighting and smart indent

– Features an integrated debugger with breakpoint 
capability and call stack visibility

– It is automatically installed with Python, is free to use, 
and does not have the host of features that tend to 
clutter many IDEs with limited benefit
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• The IDLE Development Environment
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• Starting the IDLE Text Editor
– From the Python Shell menu, select File -> New File

– The window that appears is the edit window where 
sequences of Python commands are written

– The lines written in the editor will be executed as a group 
to form a program
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• Starting the IDLE Text Editor

– Notice that the file name is currently “Untitled”

– It will be named later before running the program
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• Working in the IDLE Text Editor
– The lines of code in the edit window below have an 

intentional error

– Errors in programming are called bugs and are removed 
by “debugging” the program
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• Working in the IDLE Text Editor
– Running this will show one way that IDLE indicates errors
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• Double-check that the three lines are exactly as shown

– If something was mistyped, a second error may have 
been created
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• Working in the IDLE Text Editor

– To run the program using the text editor window

• Press ‘F5’ on the keyboard, OR

• Select Run and then Run Module from the menu
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• Working in the IDLE Text Editor

– Immediately, IDLE will pop up a little window that says, 
"Source Must Be Saved. OK to Save?“
• Click the “OK” button
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• Working in the IDLE Text Editor
– IDLE will force saving the file before running the program

• Choose a name and the “.py” file extension will be added

• After the file has been saved, Python will run the program
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• Working in the IDLE Text Editor

– There is where a lot of students go down an ever more  painful 
path

– Developing the habit of using an organized file/folder structure 
saves a tremendous amount of time and frustration

– Operating Systems fight this good habit through default folder 
locations that are file type dependent i.e. when we save a 
document, the OS defaults to “My Documents” directory

• This couldn’t be more wrong!

• Files should be organized
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• Working in the IDLE Text Editor
– Since we can save our *.py files anywhere and still run them, we are 

able to create a working folder for development and sub-folders for 
individual projects.

– Create a folder for your work in this course, and then a sub-folder for 
this example.

Chris Simber 2021 - All Rights Reserved 33

Chapter 2 Python



• Working in the IDLE Text Editor
– Now to name the file (example)…do not add the .py

– Notice the directory:   Python\My_Course_Projects\Example1
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• Working in the IDLE Text Editor

– Give it a name like “example” and click "Save“

– Immediately, Python will start running your program
• Look back at the Python Shell window to interact with it. 
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• Working in the IDLE Text Editor
– When the program runs, the prompt to “Please enter 

your name” will appear in the Python shell

– This is where input will be entered (at least for now)
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• Working in the IDLE Text Editor
– When a response to the prompt is typed and Enter is pressed, 

the intentional error in the code will surface

– In the Python shell, the red text provides information about 
the error
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• Working in the IDLE Text Editor

• The error information includes:

– A “Traceback” of the function call or calls causing the error

– The file name and line number for the error

– The line of code itself

– The type of error
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• Working in the IDLE Text Editor
– The line numbers for the program can be seen at the 

bottom right of the IDLE editor window

– Also, selecting the Option menu item will display them 
along the margin 
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• Working in the IDLE Text Editor

– The error is the result of the function call len(name) returning 

an integer which is the length of the string passed to it in 

name

– Python cannot concatenate (join) an integer onto the string 

“Your name has “, so execution stops and the error message 

appears
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• Working in the IDLE Text Editor
– To correct this, the return value from the function call to len() can 

be converted to a string using str

– Python can then concatenate (join) the resulting string to the 
literal string of characters before it, and concatenate the literal 
string after it
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• Working in the IDLE Text Editor
– Another type of error is a syntax error

– IDLE will highlight the actual code where the error occurs by 
highighting it in red and producing an error dialog

– In the example below, the character “B” was erroneously typed at 
the end of the line
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• Errors in Programming
– Syntax error – incorrect use of language specific rules 

like indentation and punctuation which will be found by 
the interpreter and the code will not execute

– Logic error – the program runs, but does not perform 
the task it was intended to perform or it produces 
incorrect results

– Runtime error – logic error that causes the program to 
stop executing
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• Errors in Programming
– The most common errors in programming:

• Misspelling words

• Forgetting case sensitivity

• Forgetting closing quotes

• Forgetting closing parentheses 
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• Running IDLE
– A quick way to run a python program - Press F5 

(Function Key)

– Recall that a quick way to save the file is Control-S

– Combining these 2 quick commands while working in 
IDLE makes things much quicker and easier

– After writing some code or making a change

Control-S Saves the code

F5 Runs the program
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• Exiting Python and IDLE
– To leave IDLE, just close the windows

• Since IDLE insists that files are saved before each 
execution, it's hard to lose changes when exiting IDLE

– To be really safe, save the program manually before 
closing the editing window

– Choose "File" on the menu bar and "Save" from the 
drop-down menu or use Control-S
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